Post Reply A Couple of Problems with Crunchy Roll
3005 cr points
Send Message: Send PM GB Post
Offline
Posted 10/2/17 , edited 10/2/17
Hi everyone. I've been with Crunchy Roll for a while now and it's been pretty smooth sailing. However, today I have a couple of issues and I was wondering if someone could help me or if maybe anyone has the same issues and has resolved them.

The first relates to the site. I keep trying to change my membership so that it autorenews premium every month but when ever I click the link to do so an orange box appears at the top of the page saying "something went wrong" Does anyone know how to fix this?

The second relates to the PS4 app . Most shows work fine, loading and playing without an issue. However, two shows(that I know of): Naruto and Blade Runner are not working for me. When I try to start the video I get an error message saying "Error. Unable to access online features. Please check your network connection settings and try again" I am a premium user and am located in the UK, if either of these things would affect anything. I've tried restarting the console and router, logging in and out. Switching from wireless internet to wired. All to no avail.

Thanks

- Liam.
55196 cr points
Send Message: Send PM GB Post
62 / M / Earth
Offline
Posted 10/2/17 , edited 10/3/17
Typically memberships already auto renew when you subscribe and put in your payment method... Are you trying to change from an annual plan or something else? In any case, you probably will need to put in a support request here if it is an actual account/billing type of issue: /contact

For the PS4, go to settings and change your "preferred language" (subtitles) to English US (not UK).

If the app itself doesn't have settings, change the preferred language here instead: /acct/?action=video

The CR videos do not have any specific UK subtitles, so finding a video with those would fail in some cases depending on how the files are stored.
3005 cr points
Send Message: Send PM GB Post
Offline
Posted 10/2/17 , edited 10/2/17
Great thanks for the quick reply

PS4 advice worked a treat. The language was set to 'default' so I put it on US and hey presto is worked!

In terms of the billing issue; I signed up with monthly renewal. I thought about changing from premium to free so I turned off the auto renew. I changed my mind and wanted to turn auto renew back on which is where I found the issue. I will do as you suggested and contact CR about the issue.

Thanks again for the help.

- Liam
You must be logged in to post.