English subtitle don't work!
3265 cr points
Send Message: Send PM GB Post
M / The Land Of Ooo
Offline
Posted 6/18/12 , edited 6/18/12
Every video I tried (mostly poyopoyo) has Spanish subtitles by default for some reason... even though we don't even have Spanish minorities where I live, there is no trace of Spanish-speaking population. Anyway that's not the problem! The problem is that even when I press the "English (US) subtitles" button it's still in Spanish! I don't speak Spanish! I don't even know how to say yes/no or hi ! A little help please ?

Edit: in the title of the topic I meant to write "English subtitles don't work"....
Posted 6/18/12
Tried Video Preferences in account settings?
44178 cr points
Send Message: Send PM GB Post
24
Offline
Posted 6/18/12

Adreaz wrote:

Every video I tried (mostly poyopoyo) has Spanish subtitles by default for some reason... even though we don't even have Spanish minorities where I live, there is no trace of Spanish-speaking population. Anyway that's not the problem! The problem is that even when I press the "English (US) subtitles" button it's still in Spanish! I don't speak Spanish! I don't even know how to say yes/no or hi ! A little help please ?

Edit: in the title of the topic I meant to write "English subtitles don't work"....


Go to the bottom of the page and click "Español" and then click "English (US)". This should set the language to Spanish and then back to English. It might fix the issue. If it doesn't then go to video preferences and make sure it's set to English.
3265 cr points
Send Message: Send PM GB Post
M / The Land Of Ooo
Offline
Posted 6/19/12
I fixed it, thanks!
You must be logged in to post.