First  Prev  1  2  3  4  5  6  7  8  Next  Last
Post Reply Stream Consistently Skips 10-20 Seconds
17020 cr points
Send Message: Send PM GB Post
41 / M / Las Vegas, NV
Offline
Posted 12/7/13

agent8261 wrote:

Here's what I speculate is going on:

During the skips there is some sort of background transition going on, maybe a server switch, or some network transition, maybe the video is being sent in chunks and wherever the break is, that's a chunk.

I guessing that problem comes in when it resyncs the video it thinks that it's further ahead then it suppose to be. I noticed that the fast-forward time is of by a few seconds. This makes me believe that the time the video is on and the time the app thinks it's on are out of sync.

Maybe a concurrency bug cause the times to go out of sync?

Anyway that's my totally uneducated guess.


I've always assumed it was a corrupt keyframe, or maybe a corrupt delta frame causing the video to skip to the next keyframe. By rewinding to just after the corruption point, the stream can reconstruct enough of the signal to keep playing, but playing through the corruption is impossible.
8195 cr points
Send Message: Send PM GB Post
20 / M / Konoha
Offline
Posted 12/8/13
Sometimes the episode will work for me, sometimes it doesn't. It's really annoying but it's great to know it's being worked on. Until then, I guess I'll stick to my wireless keyboard and mouse and HDMI hook up.
14021 cr points
Send Message: Send PM GB Post
Offline
Posted 12/13/13

eyeofpain wrote:


agent8261 wrote:

During the skips there is some sort of background transition going on, maybe a server switch, or some network transition, maybe the video is being sent in chunks and wherever the break is, that's a chunk.


Again, any network issues or switching to a different CDN server seems unlikely, since the issue seems so consistent, at least for each user. And the "chunk" explanation doesn't really make sense since I don't believe most video is packeted that way, but maybe the format for the 360 is odd that way.

In either case, speculating doesn't really help solve anything when we don't have access to the information that the eng/dev teams do, otherwise all we're doing is making wild guesses.


Speculation is more for curiosity and discussion than an attempt to be helpful.
14021 cr points
Send Message: Send PM GB Post
Offline
Posted 12/13/13

primeaspect wrote:
I've always assumed it was a corrupt keyframe, or maybe a corrupt delta frame causing the video to skip to the next keyframe. By rewinding to just after the corruption point, the stream can reconstruct enough of the signal to keep playing, but playing through the corruption is impossible.


Maybe. That would explain why re-encoding the file fixes the problem, but it doesn't explain why on the PC it works fine. Unless whatever they use to render the video is worst than in browser rendering, which I find hard to believe.
The Wise Wizard
77923 cr points
Send Message: Send PM GB Post
54 / M / U.S.A.
Offline
Posted 12/14/13

agent8261 wrote:

Maybe. That would explain why re-encoding the file fixes the problem, but it doesn't explain why on the PC it works fine. Unless whatever they use to render the video is worst than in browser rendering, which I find hard to believe.

The Flash streams for web browsers are not only a different encode, but also served from a different CDN. (The last info I have was that CR uses Akamai for the PC streams, and Limelight for all devices).

24025 cr points
Send Message: Send PM GB Post
30 / M / New York
Offline
Posted 3/21/14
It's a shame this hasn't been fixed yet. Almost every single episode I watch skips ahead 15-20 seconds. Sometimes it even happens multiple times an episode.

Other than that, the app works fine.
66049 cr points
Send Message: Send PM GB Post
M / PA
Offline
Posted 3/21/14
given up. just hdmi ing it from my laptop to the tv x_x rip in peace xbox
24005 cr points
Send Message: Send PM GB Post
Offline
Posted 4/3/14
Nice to know I'm not the only one having this problem...

I hit it on several episodes of Silver Spoon and Hoozuki no Reitetsu this week, but it has been happening for several months on nearly every show I watch.

For me, it seems to be about 5 seconds that it skips, and the work around of rewinding a bit makes it play the skipped chunk.

No issues when watching on my laptop.
14382 cr points
Send Message: Send PM GB Post
21 / M / Montreal,Quebec,...
Offline
Posted 4/4/14
Well until they fix this problem I wont bother giving CR my money. Still can't believe they haven't fixed this yet.
44095 cr points
Send Message: Send PM GB Post
33 / M / Guadalajara, Mexico
Offline
Posted 4/7/14
Just to add up, I'm having the same issue with a whole bunch of episodes. Most of them from the current season, so they should have all the newest encode/technology you are using. It gets pretty annoying from time to time, so I hope this can be fixed ASAP.
18027 cr points
Send Message: Send PM GB Post
25 / M
Offline
Posted 4/16/14
Agreed with above, if you try to watch some of the newly loaded fairy tail episodes (especially those from the grand magic games arc) it will skip ahead a minute, then skip back 2 minutes, then skip forward again, to the point where you will watch the same scene 2-3 times, then it will just you ahead 5 minutes past where the scene was. This is just ridiculous.
4017 cr points
Send Message: Send PM GB Post
18 / M / Santiago; Chile.
Offline
Posted 5/2/14
Im having the same issue. I cant believe they haven't fixed it considering the time the problem was spotted
24025 cr points
Send Message: Send PM GB Post
30 / M / New York
Offline
Posted 5/7/14
I guess they just don't care.
3021 cr points
Send Message: Send PM GB Post
17 / M / Canada
Offline
Posted 5/13/14
Yea the xbox app is messed it happens to me to.
9064 cr points
Send Message: Send PM GB Post
38 / F / Delaware
Offline
Posted 5/13/14
I don't think they plan on fixing it now that the xbox one has been released. I have been a paying member for well over a year and I can't rember a time when it didn't do it at least every few eps
First  Prev  1  2  3  4  5  6  7  8  Next  Last
You must be logged in to post.