Post Reply Mushi-Shi episode 3 subtitles missing on Roku
Koda89 
33626 cr points
Send Message: Send PM GB Post
27 / M / Oklahoma City, OK
Offline
Posted 4/18/14
I tried the episode on other devices and it has subtitles, but on Roku it doesn't. Just letting y'all know.
43668 cr points
Send Message: Send PM GB Post
60 / M / Earth
Offline
Posted 4/18/14

Koda89 wrote:I tried the episode on other devices and it has subtitles, but on Roku it doesn't. Just letting y'all know.
You need to give it time for all the encodes to catch up on devices. The web version gets 4 resolutions but soft-coded subs, so that finishes first. The device versions have hard-coded subs, so that requires producing multiple encodes with all the different possible languages, and the lower resolutions go first because they are smaller and faster.

If I don't see two dots and missing or other language subs, I go watch something else and come back to it. To maximize your Roku viewing, you should give it about an hour after trying the first time, otherwise, you will get, as you found, either no subtitles or sometimes a different language if that finishes first. Even after the English (and other) subs finish for the low resolutions, the "two dot" (480p) resolution will still be delayed a bit after that. It's just the way it is due to all the work that has to be completed to produce all the resolutions in all the languages. I'm actually a bit worried that 720 and 1080, when the come out, will cause it to be delayed even further...
You must be logged in to post.