Post Reply Why some GIF's work and others don't?
Member
16430 cr points
Send Message: Send PM GB Post
Beyond The Boundary
Offline
Posted 6/26/15
Hey everyone,

First of all thanks to all for creating this group and posting all those tips on how to fix GIF's. Also for all the help in fixing peoples GIF's and taking requests for new ones.

So I was hoping someone could help me with my GIF related issues.

I just started making GIF's less than a month ago or so. I use Adobe Photoshop Elements 13 to make them. I isolate the portion I want from either a stream from Crunchyroll or youtube and just hit play, pause like crazy and print screen. I paste each image in PS and then copy every single one in the first one (layers) and then crop the potion i want using the square select tool, then crop option. Finally is the GIF is to big to animate I resize it and then Save to Web, uncheck Transparency. I check the Animate box and set it to Forever loop and a new time.

When i click on the GIF it opens up in my browser with no issues whatsoever. It's just perfect! But off course when I upload it to Crunchyroll I have issues.

the problems I am having are that they are either choppy or they move like a closeup zoom. I make sure I crop it using the Crunchyroll cropping toll starting with the upper left corner and then the lower right corner.

Now this problem doesn't happen with all my GIF's, only with a select few. And sometimes when I upload a GIF it will work perfectly but when I try to upload it again later with an extra modification it will have the same issues. Or I just can't recreate whatever i did right the first time. Even if I use the same size and everything else I used before.

Other times the problem will be fixed if I size it down to the minimum but it's to small.

Since these issues only happen when I upload them to my profile picture or my pictures folder I have to believe something is happening after i upload them. Since they look fine when I open them with any browser.

Now the strange part is that if I see the GIF's in my Photo album in my profile I can see them rotating through these issues. But when I paste them here (bellow) or click on them they problems are not apparent. Only if I see them directly in my Photo Album or when I click edit picture.

Here are a couple of GIF's with those problems:





Would appreciate any help and to know how to fix this and stop it from happening again.
Pro
19406 cr points
Send Message: Send PM GB Post
M
Offline
Posted 6/26/15


This isn't going to help but..
I just saved the photos that you posted and I put them in my photo album, and it looked normal for me(No choppiness or close ups)

deadpanditto . Do you know a solution to this?
Pro
19406 cr points
Send Message: Send PM GB Post
M
Offline
Posted 6/26/15


Try uploading this to your Photo Album
Member
16430 cr points
Send Message: Send PM GB Post
Beyond The Boundary
Offline
Posted 6/27/15
Thanks Waifu-Chan for looking into this,

This is very strange. Hmmm I wonder why I see these 2 GIF's all choppy and zooming in and out in my photo Album.

Ok here's what I think, would appreciate your opinion on my logic.

The GIF's look fine in my laptop and browser.

They look choppy with zooming issues after I upload them to my Crunchyroll photo album.

When I click on them in my photo album they open up in a new window with the options for Back to Album, Edit Photo, Edit Album and Add Photos showing their URL, HTML and BBCode - Here they look perfect with no issues.

When I click on Edit Photo they look choppy and with zooming issues again.

After I download them to my laptop once more they look fine.

So... Can I assume that they are perfect unless they show any problems on my laptop after I create them and before uploading them to Crunchyroll?

And unless they show any issues in all the option on Crunchyroll I can assume they are fine as well?

And finally to make sure I should download them and if they are free of issues then they are fine?

Still I want to know why they show these issues in the first place without having any. I'm just a person that needs to know, figure things out.

I just learned how to make GIF's this month and want to learn more, also love fixing them so...

Well thanks again Waifu-Chan for your comments. Look forward to your comments with my last observations and conclusions.
Master
79737 cr points
Send Message: Send PM GB Post
49 / M / KC
Offline
Posted 6/30/15
I've seen this problem before. I'm not really sure what is causing it. I suspect it has something to do with an optimization that PhotoShop does but CR doesn't handle quite right. I definitely see it when there is a high level of black in the image. And it mostly happens when CR is showing a "thumbnail" in things like the Photo Album.

My solution has been to use GIMP's unoptimize feature on anything before uploading.
You must be logged in to post.