Post Reply Videos freeze a few minutes after being unpaused
2031 cr points
Send Message: Send PM GB Post
21 / M
Offline
Posted 9/6/15
When I pause a video for at least a few minutes, upon being unpaused it only runs a minute or two before freezing. I have to refresh the page to continue watching it.

This is not my internet connection. The freezing occurs even at 480p, but I can stream without the freezing at 1080p if I don't pause. It does not occur on my phone.
This is not my internet connection. The freezing occurs even at 480p, but I can stream without the freezing at 1080p if I don't pause. It does not occur on my phone.
This is not my internet connection. The freezing occurs even at 480p, but I can stream without the freezing at 1080p if I don't pause. It does not occur on my phone.


I use Chrome. I've tried restarting it, and increased its cache size to 2 GB. Anyone had or fixed this issue before?
2246 cr points
Send Message: Send PM GB Post
30 / F / Canada
Offline
Posted 9/6/15
I know what you mean! It happens to me all the time on Crunchyroll!!
1027 cr points
Send Message: Send PM GB Post
Offline
Posted 9/6/15
Yeah it happens to me all of the time as well. I'm on a university connection with 664.70 Mbps download and 270.06 Mbps upload. It is extremely annoying.

I'm "pretty sure" (read: "completely guessing with no technical experience") that the issue is how CR buffers the video. If you pause the video for some set amount of time, then CR will completely stop buffering the video. When you un-pause the video, CR will not restart buffering unless you refresh the page. I suppose this is the case so people with slower internet connections do not attempt to buffer two or three other videos in the background while watching one in their main tab.

I just accept that if I want to watch an episode, I had better watch it all the way through without a break. Or if I take a break, I accept that I'd better refresh the page before I continue.
2031 cr points
Send Message: Send PM GB Post
21 / M
Offline
Posted 9/6/15

Blizzaragaja wrote:

Yeah it happens to me all of the time as well. I'm on a university connection with 664.70 Mbps download and 270.06 Mbps upload. It is extremely annoying.

I'm "pretty sure" (read: "completely guessing with no technical experience") that the issue is how CR buffers the video. If you pause the video for some set amount of time, then CR will completely stop buffering the video. When you un-pause the video, CR will not restart buffering unless you refresh the page. I suppose this is the case so people with slower internet connections do not attempt to buffer two or three other videos in the background while watching one in their main tab.

I just accept that if I want to watch an episode, I had better watch it all the way through without a break. Or if I take a break, I accept that I'd better refresh the page before I continue.


That was my hunch too; I'm willing to bet it buffers a bit and then the HTTP session expires. I was hoping to fix it by increasing chrome's buffer limit, but no luck there.
You must be logged in to post.