First  Prev  1  2  Next  Last
Post Reply Latest Update 1.1.5 Broke Playback
5 cr points
Send Message: Send PM GB Post
Offline
Posted 9/26/15 , edited 10/2/15

arukarudo wrote:
So i wonder if a person with a problem to access "metrics.brightcove.com" for some reason, wouldn't have that same problem as i had cause of adway.


I can confirm that this is the issue with the Android Player v1.1.5.

Many managed networks have begun to employ black-lists in an effort to reduce bandwidth and unwanted reporting. Crunchyroll and other app designers need to understand that they are hindering app functionality by requiring access to non-crtitical domains that might be black-listed.

As things are now, if you are unable to white-list "metrics.brightcove.com" in you network, you have to downgrade to v1.1.4. Hopefully Crunchyroll app developers will account for managed networks beyond their users control in their next version.

-[]D
30009 cr points
Send Message: Send PM GB Post
Offline
Posted 9/28/15

arukarudo wrote:

I did some tests here installing and reinstalling the crunchroll app and I noticed that when i had the adway app disabled, crunchyroll worked flawlessly. Adway is an app that edit the hosts file adding a lot of domains to block ads, so I started messing with the huge hosts file to identify what was the domain causing that problem by being blocked... and after a thousand of reboots, I found out that when "metrics.brightcove.com" is blocked I get that error "There was a problem playing the video. Please try again, or contact support if the problem persists."

So i wonder if a person with a problem to access "metrics.brightcove.com" for some reason, wouldn't have that same problem as i had cause of adway.

Btw I did some research with that domain name and found this, https://support.brightcove.com/en/video-cloud/docs/domains-and-ports-must-be-accessible-video-cloud dunno if crunchyroll started using this on their new app, cause I didn't had any problem even with that domain blocked with the 1.1.4 crunchyroll app.

So for myself I solved my problem by adding the domain to my whitelist on adway, I hope this info helps to recreate the bug and find the problem. I'm available to provide any other info needed.


thanks!! it worked like a charm, in 4 different devices
14012 cr points
Send Message: Send PM GB Post
33 / M / USA
Offline
Posted 9/28/15
I recieved an email from there support team saying I should disable my ad-block and whitelist brightcove for their metrics system.

No thank you. I just downgraded to 1.1.4 instead. works just fine. I will not be disabling or compromising my privacy/security.

40030 cr points
Send Message: Send PM GB Post
33 / M / Colorado, USA
Offline
Posted 9/29/15 , edited 9/29/15
I just added an exception to my AdFree app for "metrics.brightcove.com" and got it working on 1.1.5. I'll be trying it out at work today (during lunch of course ) to see if I can play through that thick firewall on the guest Wi-Fi.
WVS11 
5012 cr points
Send Message: Send PM GB Post
26 / M / Québec
Offline
Posted 10/1/15 , edited 10/1/15
Thank you! arukarudo, you da real MVP !
5018 cr points
Send Message: Send PM GB Post
Offline
Posted 10/1/15
This was the solution for me as well. Worked like a charm. Thank you!
Der Zoodirektor
23419 cr points
Send Message: Send PM GB Post
34 / M / Germany
Offline
Posted 10/1/15 , edited 10/1/15
We released version 1.1.6 the other day, which also adressed this issue. Anyone who downgraded to 1.1.4 from dubious 3rd party sources should uninstall and install the new version.
5005 cr points
Send Message: Send PM GB Post
Offline
Posted 10/1/15

shinryou wrote:

We released version 1.1.6 the other day, which also adressed this issue. Anyone who downgraded to 1.1.4 from dubious 3rd party sources should uninstall and install the new version.


Does not fix the problem. The same error message occurs on multiple devices in my network.

Those of us unable to whitelist "metrics.brightcove.com" will still be forced to use 1.1.4
30009 cr points
Send Message: Send PM GB Post
Offline
Posted 10/2/15 , edited 10/2/15

ijoeah wrote:


shinryou wrote:

We released version 1.1.6 the other day, which also adressed this issue. Anyone who downgraded to 1.1.4 from dubious 3rd party sources should uninstall and install the new version.


Does not fix the problem. The same error message occurs on multiple devices in my network.

Those of us unable to whitelist "metrics.brightcove.com" will still be forced to use 1.1.4


seems like 1.1.6 broke the "whitelist fix" for me =/

edit: whitelist fix + clicking in "try again" when video is playing fix it for me in 1.1.6
52050 cr points
Send Message: Send PM GB Post
44 / M
Offline
Posted 10/6/15
What say you CR? Is someone fixing the issue or are you abandoning the Android platform?
First  Prev  1  2  Next  Last
You must be logged in to post.