Post Reply Headphone sound switching sides, help!
10071 cr points
Send Message: Send PM GB Post
25 / M / Washington
Offline
Posted 10/2/15
About 2 months back when taking off my 2 year old G35's the earpiece broke off so i decided to buy a new pair, after getting it i plugged it in and used it with no problems whatsoever. After about a day or two I was playing dayz and noticed that sounds that should be coming from the right such as my friend shooting were coming from the opposite direction. Every sound was reversed, right from left - left from right, front from back - back from front etc.. nothing i did would fix the problem besides unplugging and plugging the headset back in but this only worked until i started playing another game then seemingly at random it would reverse the sounds again. I've read countless posts everywhere i could think to look and tried every "solution" people had to offer. A few things i tried were reinstalling the logitech software, reinstalling all the things related to my headphones in the device manager and even returning and getting another new pair of g35s. I thought that maybe I bought a faulty pair of g35s which is why I exchanged them but the new pair is having the same issues which would make me thing that it is a problem with my computer but the thing that really confuses me is that if i take my old broken pair of g35s with the broken earpiece (sorta fixed with duct tape) and plug them in they work perfectly fine, no audio swapping at all. I'd just say to hell with it and use those if they weren't so damn uncomfortable because of the duct tape fix.

So after that wall of text here is my question, Have any of you had this problem before? Have you managed to fix it? If so would you please instruct me on how I could go about fixing it because it is really starting to make my head hurt.
18466 cr points
Send Message: Send PM GB Post
43 / M / Finland
Offline
Posted 10/3/15
Have you tried updating the driver software?
10071 cr points
Send Message: Send PM GB Post
25 / M / Washington
Offline
Posted 10/3/15
yes, i updated it one time and uninstalled it then reinstalled it in another attempt to fix it
You must be logged in to post.