Post Reply Roku app won't stream anything??
5025 cr points
Send Message: Send PM GB Post
19 / F
Offline
Posted 7/17/16
I have a Roku, and the latest version of the crunchyroll app.

Whenever I try to load a video, I always get this error:
"Playback Interrupted. Sorry, the app can't continue playing your video because of an unexpected error. Please check your connection."

However, Netflix and other apps work completely fine (and in HD).

And my internet connection is fantastic (the only thing on my bandwidth are this roku, my cellphone, and computer).

I've tried deleting the app, and redownloading it. I've tried factory restoring the roku. I've tried unplugging it. I've tried moving the roku around in the room. At a loss of how to resolve the issue. I'm a premium member too, so it shouldn't be an issue of the commercials interfering with the stream...

Internet specs:

Download speeds: 72 mbp/s
Upload speeds: 6 mbp/s
Ping: 16ms
Jitter: 3ms
Packet Loss: 0%
Line Quality: A
29118 cr points
Send Message: Send PM GB Post
83 / F / Bite the pillow.
Offline
Posted 7/17/16

KirakishouSama wrote:


Which model of Roku do you have?
5025 cr points
Send Message: Send PM GB Post
19 / F
Offline
Posted 7/17/16

Hairbelly
Which model of Roku do you have?


I have a Roku 1.
42636 cr points
Send Message: Send PM GB Post
60 / M / Earth
Offline
Posted 7/17/16

KirakishouSama wrote:

Hairbelly
Which model of Roku do you have?

I have a Roku 1.

Are you using an HDMI cable to connect to your TV or are you using the composite (red/yellow/white) plugs? I remember hearing that the latest app only works using HDMI with the setting at 1080p
5025 cr points
Send Message: Send PM GB Post
19 / F
Offline
Posted 7/18/16

asharka wrote:


KirakishouSama wrote:

Hairbelly
Which model of Roku do you have?

I have a Roku 1.

Are you using an HDMI cable to connect to your TV or are you using the composite (red/yellow/white) plugs? I remember hearing that the latest app only works using HDMI with the setting at 1080p


Unfortunately it doesn't seem to make a difference....

42636 cr points
Send Message: Send PM GB Post
60 / M / Earth
Offline
Posted 7/18/16

KirakishouSama wrote:
Unfortunately it doesn't seem to make a difference....


Sounds like you need to use the /contact link to get support then.

On the Roku, go to Settings -> System -> About to get the exact model number to put in the request so that they don't have to ask you that...

Make sure you choose "ROKU" in the "choose an option" dropdown box so it goes to the correct place.

You might also want to include the link to this thread, just in case someone there actually will read it instead of just sending you a stock response at first.

You might have to check your Spam folder for the email responses instead of your inbox, they have been known to get wrongly marked as spam...
5025 cr points
Send Message: Send PM GB Post
19 / F
Offline
Posted 7/19/16

asharka wrote:


KirakishouSama wrote:
Unfortunately it doesn't seem to make a difference....


Sounds like you need to use the /contact link to get support then.

On the Roku, go to Settings -> System -> About to get the exact model number to put in the request so that they don't have to ask you that...

Make sure you choose "ROKU" in the "choose an option" dropdown box so it goes to the correct place.

You might also want to include the link to this thread, just in case someone there actually will read it instead of just sending you a stock response at first.

You might have to check your Spam folder for the email responses instead of your inbox, they have been known to get wrongly marked as spam...


Will do, thank you for your help!
21005 cr points
Send Message: Send PM GB Post
34 / F / Nevada
Offline
Posted 7/30/16
KirakishouSama - if you do hear something on a fix for this please share. I've been having the same problem, same error, and have Roku 1 as well.
54 cr points
Send Message: Send PM GB Post
Offline
Posted 8/18/16 , edited 8/18/16
The reason the AV cables (red/yellow/white) don't work is because the 480p detection is broken(I think). (There's a bit of a wonky part in the Roku API documentation where they list only 720 as the pixel width for 480p, so there may actually be a bug in the software, or it may just be hardcoded. Either way, it doesn't make sense that both 4:3 aspect ratio and Widescreen would have 720 pixels width with 480 pixels of height).

So, if they coded it from the Roku API tutorial directly.... it creates a bug that would make 480p not work.z

https://sdkdocs.roku.com/display/sdkdoc/ifDeviceInfo

SD is 4:3, Widescreen is 16:9

Widescreen 16:9 material has only the width scaled down to fit 720 pixels instead of an unscaled 848 width.
https://en.wikipedia.org/wiki/480p

So the width could be 640, 720, 848, or 853/854 pixels

Yeah, the roku documentation and screen width conflict, it says 4:3 or Widescreen(16:9), neither of which should be 720 pixels, and yet the documentation says 720 pixels... scaling? Either way, given that documentation it's fairly easy to botch the app if you try to hardcode it and don't do proper testing.

https://en.wikipedia.org/wiki/480p
See, 720 pixels is actually 3:2 aspect ratio which isn't an available setting for the Roku, if this is what they hardcoded, it makes sense that neither widescreen nor 4:3 aspect ratios work (and they don't), so composite cables would never work.

If I'm wrong, feel free to edit this post.

Error also applies to Roku SE.
5 cr points
Send Message: Send PM GB Post
Offline
Posted 8/24/16
Has anything been figured out with this playback error yet? I was a premium member until this happened to me in November or December, but it wasn't fixed for months so I canceled my account. I'd really like to give it a try again, but not if I still can't use my Roku to watch anything.
Der Zoodirektor
23373 cr points
Send Message: Send PM GB Post
34 / M / Germany
Offline
Posted 8/24/16 , edited 10 days ago

FaeryBean wrote:

Has anything been figured out with this playback error yet? I was a premium member until this happened to me in November or December, but it wasn't fixed for months so I canceled my account. I'd really like to give it a try again, but not if I still can't use my Roku to watch anything.


If your TV supports HDMI, use a HDMI cable and set the output resolution of the Roku to 1080.
You must be logged in to post.