Post Reply Videos Just Stopped for Safari on MacOS
tacrow 
22218 cr points
Send Message: Send PM GB Post
54 / M
Online
Posted 12/26/16
Starting either late last night or this morning, I can't playback any of Crunchyroll's videos on my iMac (MacOS 10.12.2) running Safari (10.0.2).

It's fine with either Chrome (55.0.2883.95 (64-bit)) or Mozilla Firefox (50.1.0).

Opening the Developer console on Safari, I see several errors around the time I try to start any video (this example is from The Ancient Magus' Bride: Those Awaiting a Star Episode 1 – Part 1):

ReferenceError: Can't find variable: gapi (Global code - episode-1-part-1-719987:1597)

Blocked a frame with origin "https://apis.google.com" from accessing a frame with origin "http://www.crunchyroll.com". The frame requesting access has a protocol of "https", the frame being accessed has a protocol of "http". Protocols must match.

http://flash.quantserve.com/quant.swf?title=chromeless&qcv=2%2E1%2E1&pageURL=http%3A%2F%2Fwww%2Ecrunchyroll%2Ecom%2Fthe%2Dancient%2Dmagus%2Dbride%2Fepisode%2D1%2Dpart%2D1%2D719987%3Ft%3D844&publisherID=p%2D2c9Xi7EeE3Hx2&url=http%3A%2F%2Fwww%2Ecrunchyroll%2Ecom%2Fvendor%2FStandardVideoPlayer%2D10dff2a%2Eswf&config%5Furl=http%3A%2F%2Fwww%2Ecrunchyroll%2Ecom%2Fxml%2F%3Freq%3DRpcApiVideoPlayer%5FGetChromelessConfig&server=http%3A%2F%2Fflash%2Equantserve%2Ecom&lc=%5F1482779876571%5F8132&flashPlayer=MAC%2024%2C0%2C0%2C186&use%5Fexplicit%5Fconfig=1&playOnly=true&labels=chromeless&fpf=1%2D0%2D0&media=widget&videoID=1&v=1Failed to load resource: cannot decode raw data

Like I said, I can still view videos in Chrome and Mozilla, so I haven't lost access.

Please let me know if there's anything else I can do to help track down this error!
59738 cr points
Send Message: Send PM GB Post
31 / M / Dallas, TX
Online
Posted 12/26/16

tacrow wrote:

Starting either late last night or this morning, I can't playback any of Crunchyroll's videos on my iMac (MacOS 10.12.2) running Safari (10.0.2).

It's fine with either Chrome (55.0.2883.95 (64-bit)) or Mozilla Firefox (50.1.0).

Opening the Developer console on Safari, I see several errors around the time I try to start any video (this example is from The Ancient Magus' Bride: Those Awaiting a Star Episode 1 – Part 1):

ReferenceError: Can't find variable: gapi (Global code - episode-1-part-1-719987:1597)

Blocked a frame with origin "https://apis.google.com" from accessing a frame with origin "http://www.crunchyroll.com". The frame requesting access has a protocol of "https", the frame being accessed has a protocol of "http". Protocols must match.

http://flash.quantserve.com/quant.swf?title=chromeless&qcv=2%2E1%2E1&pageURL=http%3A%2F%2Fwww%2Ecrunchyroll%2Ecom%2Fthe%2Dancient%2Dmagus%2Dbride%2Fepisode%2D1%2Dpart%2D1%2D719987%3Ft%3D844&publisherID=p%2D2c9Xi7EeE3Hx2&url=http%3A%2F%2Fwww%2Ecrunchyroll%2Ecom%2Fvendor%2FStandardVideoPlayer%2D10dff2a%2Eswf&config%5Furl=http%3A%2F%2Fwww%2Ecrunchyroll%2Ecom%2Fxml%2F%3Freq%3DRpcApiVideoPlayer%5FGetChromelessConfig&server=http%3A%2F%2Fflash%2Equantserve%2Ecom&lc=%5F1482779876571%5F8132&flashPlayer=MAC%2024%2C0%2C0%2C186&use%5Fexplicit%5Fconfig=1&playOnly=true&labels=chromeless&fpf=1%2D0%2D0&media=widget&videoID=1&v=1Failed to load resource: cannot decode raw data

Like I said, I can still view videos in Chrome and Mozilla, so I haven't lost access.

Please let me know if there's anything else I can do to help track down this error!


This might be the result of a recent update to Safari, possibly related to CVE-2016-7599, which does not appear to have been published yet.
tacrow 
22218 cr points
Send Message: Send PM GB Post
54 / M
Online
Posted 12/26/16
Interesting.

I _swear_ it worked yesterday, and I've not made any updates. The App Store shows my last update on 12/13, which was the update to MacOS 10.12.2.

Though what you're saying seems to be a good match for what I'm seeing.

Still, I can't get over why it worked yesterday...

Thanks for the reply!
tacrow 
22218 cr points
Send Message: Send PM GB Post
54 / M
Online
Posted 1/2/17
Just for the record -- it seems to be working now. I've made no updates to my computer, so I don't think that's why.

I'd be curious to know what happened, but I'm glad to be up and running again.
Der Zoodirektor
26037 cr points
Send Message: Send PM GB Post
35 / M / Germany
Offline
Posted 1/2/17
Try clearing your browser and Flash player caches.
You must be logged in to post.