Post Reply Reactivating Premium - Get's error message
Posted 1/26/17
I'm trying to upgrading my account to Premium(+) when typing card information after choosing payment plan, but all I get is the message "Something is wrong with your card. Try again". Yes, I've checked on my Internet Bank, it's NOT blocked. I can use my card everywhere else, such as Steam, Amazon, et cetera. I'm also getting the error message "Something went wrong." when I'm clicking on the Premium button. And I'm getting the same issue while paying through PayPal.

What can I really do? Contacting the bank would give me the very same answer as I found on the Internet Bank, so it's not blocked. Please, help me CR staff. :/

59738 cr points
Send Message: Send PM GB Post
31 / M / Dallas, TX
Online
Posted 1/26/17 , edited 1/26/17

OctaMomentum wrote:

I'm trying to upgrading my account to Premium(+) when typing card information after choosing payment plan, but all I get is the message "Something is wrong with your card. Try again". Yes, I've checked on my Internet Bank, it's NOT blocked. I can use my card everywhere else, such as Steam, Amazon, et cetera. I'm also getting the error message "Something went wrong." when I'm clicking on the Premium button. And I'm getting the same issue while paying through PayPal.

What can I really do? Contacting the bank would give me the very same answer as I found on the Internet Bank, so it's not blocked. Please, help me CR staff. :/



You should /contact customer support directly. The forums are primarily for user-to-user support.
43866 cr points
Send Message: Send PM GB Post
55 / M / East Coast
Offline
Posted 1/26/17

OctaMomentum wrote:

I'm trying to upgrading my account to Premium(+) when typing card information after choosing payment plan, but all I get is the message "Something is wrong with your card. Try again". Yes, I've checked on my Internet Bank, it's NOT blocked. I can use my card everywhere else, such as Steam, Amazon, et cetera. I'm also getting the error message "Something went wrong." when I'm clicking on the Premium button. And I'm getting the same issue while paying through PayPal.

What can I really do? Contacting the bank would give me the very same answer as I found on the Internet Bank, so it's not blocked. Please, help me CR staff. :/



I would wait until all the new VRV ( new plan ) bugs are worked out such as HTML.5 / avaiable for all PLATFORMS not just APPS ( no PC's now )
Posted 1/27/17

FLjerry2011 wrote:


OctaMomentum wrote:

I'm trying to upgrading my account to Premium(+) when typing card information after choosing payment plan, but all I get is the message "Something is wrong with your card. Try again". Yes, I've checked on my Internet Bank, it's NOT blocked. I can use my card everywhere else, such as Steam, Amazon, et cetera. I'm also getting the error message "Something went wrong." when I'm clicking on the Premium button. And I'm getting the same issue while paying through PayPal.

What can I really do? Contacting the bank would give me the very same answer as I found on the Internet Bank, so it's not blocked. Please, help me CR staff. :/



I would wait until all the new VRV ( new plan ) bugs are worked out such as HTML.5 / avaiable for all PLATFORMS not just APPS ( no PC's now )


That's good to know. I'll have to wait then, but such a shame that it's a problem now since I recall it worked well for a few years ago.
You must be logged in to post.