First  Prev  1  2  Next  Last
Post Reply Shield TV - No internet connection?
47021 cr points
Send Message: Send PM GB Post
Offline
Posted 7/30/17
It worked briefly earlier this week, but now it's broken again.

It also doesn't work on my Playstation 4.

Crunchyroll support is useless. All they could suggest was reinstalling the app or changing my DNS settings, neither of which did anything.

I give up. I'm cancelling my subscription.
3180 cr points
Send Message: Send PM GB Post
23 / F
Offline
Posted 8/1/17
This also happens to me on my Sony Android TV (and has happened since I first downloaded the app for the TV two months ago). When trying to run the Crunchyroll app, it will sometimes say "No Internet Connection" and the app won't load (even though my internet connection is just fine...). This will happen on and off throughout a week for hours at a time, and lately it has been happening more often. It looks like it's an issue with the Crunchyroll android app.

I hope this is fixed soon.
5 cr points
Send Message: Send PM GB Post
Offline
Posted 8/21/17
Got exacly the same problem with my NVIDIA shield for a few weeks now. I started a log to try finding what the problem is and although it's still too early to tell exacly what is up, It seems like the trigger to this problem is when android goes into a sleep state while having the CR app still open. I will try to start closing the app from now on, but it's hard to tell (really need someone from CR on this thread please)
jsamyn 
5 cr points
Send Message: Send PM GB Post
Offline
Posted 8/25/17
I may have found a solution to this issue on the Amazon Fire TV.



As with the previous posts in this thread, the app would work fine and then later that same day I'd get the dreaded No Internet connection. Strangely enough all the other apps on the Fire TV would work (Prime, Netflix, etc). I've tried all the usual suspects: clearing the cache, forcefully stopping the app, uninstalling/reinstalling, power off/on, unplug ethernet cable, switch between wireless and ethernet, restart the whole cable modem/router/device chain... all to no avail.

I noticed that sometimes I'd go into the app and it would show a screen with an empty queue and as soon as I'd select anything from the menu it would also tell me no internet available. Subsequent tries would lead to that same message instantaneously, as though it's not even trying. It then occurred to me that this usually happens if I just press the home screen on the remote, which takes me out of the app back to the Fire TV home screen. If I effectively back out of the app (pressing the back button), it will then ask me if I want to leave the application. Clicking yes there also takes me to the home screen of course, but so far the app hasn't given me that error once.

It feels like there's a cacheing/timing issue going on and the only way to properly prevent it is to exit the app "the right way". I don't know why clearing the cache or even rebooting the device wouldn't clear that out immediately, but when the issue happened it would always become available after a while (I'm not exactly sure how long that was, perhaps an hour, perhaps less).
64054 cr points
Send Message: Send PM GB Post
43 / M
Offline
Posted 9/8/17 , edited 9/8/17

thoomfish wrote:

It worked briefly earlier this week, but now it's broken again.

It also doesn't work on my Playstation 4.

Crunchyroll support is useless. All they could suggest was reinstalling the app or changing my DNS settings, neither of which did anything.

I give up. I'm cancelling my subscription.


Broken again for me as well. Going to start a new thread, hopefully get some attention from support:

Phone Model: Shield Android TV
Streaming Via: Wifi AND hardwired
Service Provider: Comcast
Android OS: 7.0
App Version: 1.0.31

Symptoms:
1) When Crunchyroll is not exited and the system goes to sleep, upon waking the system Crunchyroll does not allow for browsing (empty context menus)
2) On occasion (more so since the last update), upon exiting the app and attempting to relaunch the app, Crunchyroll splash screen shows up and then the user receives the dreaded "No Internet Connection" error. User can launch other internet dependent applications (Netflix, outube, etc), but cannot get Crunchyroll to get past the "No Internet Connection" error.

Attempted work arounds:
1) Clear Cache (app)
2) Clear Cache and Data (app)
3) Uninstall/Reinstall Crunchyroll App
4) Switch from hardwired connection to wifi connection
5) Use Google DNS
6) Use Comcast DNS
7) Cast Crunchyroll from Chrome on laptop (WORKS)
8) Tether device to cell phone and launch Crunchyroll App on device (WORKS)
9) Clear Device Cache
10) Add manual proxy to shield IP settings (WORKS?)
11) Bounce router
12) Bounce modem
13) Bounce router and modem

What is NOT the problem:
Not Comcast because it is happening on multiple providers (ATT Uverse was listed by the OP)
Not Shield because I can tether to my cell phone and the app works immediately.
Not DNS (tried Google and Comcast DNS)



Something changed in the past few months to cause this to happen more often than it had been. After adding proxy, the app started to work again. Removed proxy and the app still worked, so I am working again. However, I also just crossed over into the next day, so I cannot say for sure adding then removing a proxy was what solved the issue. I will have to wait for this to happen again (the next time I forget to exit completely out of the app before the Shield goes to sleep).

That still leaves us with something on the CR side returning a bad code (404, 500, etc) to a specific IP address, which to me sounds a lot like an issue with anti DOS configuration or firewall timeouts on the SERVER side. This apparently only happens when the app is not cleanly exited before timing out, cannot get to com.crunchyroll.chruncyroid to look at logs without root, or at least I cannot FIND it, so that's about as much info as I can provide.

If someone could test the proxy trick out to see if it really fixed it after adding and removing proxy, or if it was just dumb luck, that would be appreciated.
10 cr points
Send Message: Send PM GB Post
Offline
Posted 9/19/17
Yeah, I'm getting the same exact problem.

I've tried uninstalling/reinstalling, and every other solution discussed in this thread.

Nothing fixes it, and like everyone else, my other apps all work fine and my Shield TV is on a wired connection.

I have no idea how to fix this, but I'm paying for this service and quite literally can't use it in any way

Is it still so that they basically don't give a fuck about the Android TV app development? I see the last update was around seven months ago, and that's not so for the other platforms.

How do I even go about fixing this? Cancel and get VRV or is it full of the same problems?
5005 cr points
Send Message: Send PM GB Post
Offline
Posted 22 days ago
How is there no response from CR staff at all about this? It's ridiculous. Like you all I'm having the exact same issue, and while it used to happen every once in a while it is becoming more common and really pissing me off. I'm even paying $10/mo for the VRV subscription, but of course there is no VRV app for Android TV, so I'm still using the Crunchyroll app, and every night when I settle down to watch the anime I'm paying for it's a coin flip whether or not it works. Absurd.
First  Prev  1  2  Next  Last
You must be logged in to post.