First  Prev  1  2  Next  Last
Post Reply [BUG] html5 player (beta)
5019 cr points
Send Message: Send PM GB Post
Offline
Posted 8/20/17
Hi Guys,

The HTML5 player worked a week ago.
Yesterday I finally wanted to sit down and I got this in the javascript console:
blob:http://www.crunchyroll.com/b55aaac0-b9e2-4293-a8ea-31c74acac2c4:45 Uncaught SyntaxError: Unexpected token {
Which is here:

};t.default=function(e){return new h(e)},e.exports=t.default
(e){return new h();
},function (e,t){function n(e){

Which doesn't seem to me like valid javascript... It looks like a copy paste went wrong somewhere...
It seems somebody wanted to copy paste almost the same but made a booboo on copying.

The net result is that the player is started, the spinner spins, and it's dead in the water not having played a single frame.
This is of course in debug mode with cache turned off, so I should have the latest release.

Another question: is there a group/forum/ticketing system for discussing the beta player?
17018 cr points
Send Message: Send PM GB Post
29 / M
Offline
Posted 8/20/17 , edited 8/21/17
Honestly the HTML5 player never worked for me. It sometimes starts but has the worst buffer going on. I have a 150/150 line so that shouldn't be a problem.

But yes I get this exact error too.
5019 cr points
Send Message: Send PM GB Post
Offline
Posted 8/21/17
Ok, I think I just will regulalry reload and check...
It looks like they use a framework that needs to be compiled... Maybe I can fix something so it uses a working compiled version.
In the end, crunchy just needs to fix this of course, and rather soon than late.
Tup3x 
4274 cr points
Send Message: Send PM GB Post
28 / M / Finland
Offline
Posted 8/21/17 , edited 8/21/17
It looks like they broke it again for Firefox and Chrome. Wasted premium+ sub...
5696 cr points
Send Message: Send PM GB Post
34 / F / Washington
Offline
Posted 8/21/17
I'm getting "plugin not supported" on Chrome mobile after Chrome updated yesterday.
108253 cr points
Send Message: Send PM GB Post
57 / M / U.S.A. (mid-south)
Offline
Posted 8/21/17

LikaLaruku wrote:

I'm getting "plugin not supported" on Chrome mobile after Chrome updated yesterday.

Only Premium+ members have access to the HTML5 beta (or any beta). Your profile shows you are "only" a Premium member. Chrome's mobile browser doesn't support Flash, and that's the only player you are being offered, thus the result you are getting.

65022 cr points
Send Message: Send PM GB Post
42 / M
Offline
Posted 8/22/17
I was excited because the HTML5 player worked on firefox and chrome under Linux for a week or two then broke again something in the last week or so.

It is now back to non functional under Linux.

raabnz 
59025 cr points
Send Message: Send PM GB Post
35 / M
Offline
Posted 8/23/17 , edited 8/23/17
CR really needs a beta test forum for people to report such bugs, what is the point in actually beta testing something if there's no avenue to report directly to those that can fix it in a reasonable amount of time.

I emailed support but got the usual canned response saying check the knowledge base.. yeah, I'm not alone in this problem so the KB isn't going to help me.

It's been broken for over 2 weeks now, but does work in Safari

I get the feeling the HTML5 player is just a token effort with low priority until they actually have to do something about it when flash is dropped.
Tup3x 
4274 cr points
Send Message: Send PM GB Post
28 / M / Finland
Offline
Posted 8/24/17
It seems to be disabled completely at the moment. Just grey "HTML5 player coming soon!".
65022 cr points
Send Message: Send PM GB Post
42 / M
Offline
Posted 8/24/17 , edited 9/4/17
I bumped my membership level just to use the html5 player.

I guess its time to bump it back down.
17012 cr points
Send Message: Send PM GB Post
Offline
Posted 8/26/17
CR needs to hire a competent internal dev team. They're clearly just outsourcing development on this project, since we constantly get these amateur mistakes made that totally break the HTML5 player.
Orianj 
54023 cr points
Send Message: Send PM GB Post
35 / M
Offline
Posted 8/28/17 , edited 9/4/17
I bumped my membership up to premium+ because the flash player no longer works for me at all in Chrome, even with it set to always allow and when right clicking it and selecting run. With the html 5 player now not being available either I can only watch CR via my tablet which is iffy at best. This really needs to be resolved soon. It's a waste of my sub.
59905 cr points
Send Message: Send PM GB Post
31 / M / Dallas, TX
Online
Posted 8/28/17

Orianj wrote:

I bumped my membership up to premium+ because the flash player no longer works for me at all in Chrome, even with it set to always allow and when right clicking it and selecting run. With the html 5 player now not being available either I can only watch CR via my tablet which is iffy at best. This really needs to be resolved soon. It's a waste of my sub.


If you're on Windows 10, have you tried the Windows app or this unofficial Chrome extension: https://chrome.google.com/webstore/detail/cr-hls-player/aeajdeepnjjdekpbicjhfldagkjndjid?
53111 cr points
Send Message: Send PM GB Post
61 / M / Earth
Offline
Posted 8/28/17 , edited 8/28/17

Orianj wrote:

I bumped my membership up to premium+ because the flash player no longer works for me at all in Chrome, even with it set to always allow and when right clicking it and selecting run. With the html 5 player now not being available either I can only watch CR via my tablet which is iffy at best. This really needs to be resolved soon. It's a waste of my sub.


In Chrome, on the left side of the URL bar, just before the Address, there is a circled letter ⓘ. While anywhere on Crunchyroll, click that "i" and in the drop-down, allow Flash to run. This whitelists CR only for Flash and should allow the player to work again.

If that doesn't work, start disabling extensions one at a time... I have seen reports of those being a problem sometimes.
Orianj 
54023 cr points
Send Message: Send PM GB Post
35 / M
Offline
Posted 8/28/17 , edited 9/4/17
Tried both of those (already mentioned that I had set it to allow the flash player no less) . Neither works. Thanks though.
First  Prev  1  2  Next  Last
You must be logged in to post.